<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US">

<head profile="http://gmpg.org/xfn/11">

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N4N25R');</script>
<!-- End Google Tag Manager -->
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<title>Increasing SQLite Performance - Devart Blog</title><style id="rocket-critical-css">https://blog.devart.com/wp-content/cache/min/1/07109087fd9ec4ac9deb996e4095fe15.css https://blog.devart.com/wp-content/cache/min/1/42e3c002374a46279cf84c7cd3eb139f.css</style><link rel="preload" href="https://blog.devart.com/wp-content/cache/min/1/386643c3d2d3735be5794309a2354d87.css" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" media="all" data-minify="1" />


<!-- site full CSS + syntax-highlighter -->
</link>

<link rel="icon" href="/images/favicon.ico" type="image/x-icon" />
<link rel="icon" href="/images/favicon.ico" type="image/png" />





<link rel="alternate" type="application/rss+xml" title="Devart Blog RSS Feed" href="https://blog.devart.com/feed" />
<link rel="pingback" href="https://blog.devart.com/xmlrpc.php" />
<link href="https://fonts.googleapis.com/css?family=Fira+Sans:100,100i,200,200i,300,300i,400,400i,500,500i,600,600i,700,700i,800,800i,900,900i|Open+Sans:300,300i,400,400i,600,600i,700,700i,800,800i&#038;display=swap" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" rel="preload" />


<style>
.page-title {
color: #6A6A6A;
position: static;
}
</style>

<!-- This site is optimized with the Yoast SEO plugin v12.4 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://blog.devart.com/increasing-sqlite-performance.html" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Increasing SQLite Performance - Devart Blog" />
<meta property="og:description" content="One the major issues a developer encounters when using the SQLite DBMS in his applications is its performance issue. Perhaps, a classic case everyone gets into when using SQLite for the first time is very slow execution of multiple INSERT/UPDATE/DELETE operations. Indeed, sequential executions of not even thousands, but hundreds of INSERTs into a table &hellip;" />
<meta property="og:url" content="https://blog.devart.com/increasing-sqlite-performance.html" />
<meta property="og:site_name" content="Devart Blog" />
<meta property="article:tag" content="litedac" />
<meta property="article:tag" content="performance" />
<meta property="article:tag" content="sqlite" />
<meta property="article:tag" content="tips and tricks" />
<meta property="article:section" content="How To" />
<meta property="article:published_time" content="2015-12-21T12:44:20+00:00" />
<meta property="article:modified_time" content="2019-11-28T12:05:43+00:00" />
<meta property="og:updated_time" content="2019-11-28T12:05:43+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="One the major issues a developer encounters when using the SQLite DBMS in his applications is its performance issue. Perhaps, a classic case everyone gets into when using SQLite for the first time is very slow execution of multiple INSERT/UPDATE/DELETE operations. Indeed, sequential executions of not even thousands, but hundreds of INSERTs into a table [&hellip;]" />
<meta name="twitter:title" content="Increasing SQLite Performance - Devart Blog" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://blog.devart.com/#website","url":"https://blog.devart.com/","name":"Devart Blog","potentialAction":{"@type":"SearchAction","target":"https://blog.devart.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://blog.devart.com/increasing-sqlite-performance.html#webpage","url":"https://blog.devart.com/increasing-sqlite-performance.html","inLanguage":"en-US","name":"Increasing SQLite Performance - Devart Blog","isPartOf":{"@id":"https://blog.devart.com/#website"},"datePublished":"2015-12-21T12:44:20+00:00","dateModified":"2019-11-28T12:05:43+00:00","author":{"@id":"https://blog.devart.com/#/schema/person/e5af8ea5ceb0f8ed1a69d020fe74720e"}},{"@type":["Person"],"@id":"https://blog.devart.com/#/schema/person/e5af8ea5ceb0f8ed1a69d020fe74720e","name":"DAC Team","image":{"@type":"ImageObject","@id":"https://blog.devart.com/#authorlogo","url":"https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=96&d=mm&r=g","caption":"DAC Team"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Devart Blog &raquo; Increasing SQLite Performance Comments Feed" href="https://blog.devart.com/increasing-sqlite-performance.html/feed" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	
<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://blog.devart.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}
</style>
<link rel='https://api.w.org/' href='https://blog.devart.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.devart.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.devart.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.3" />
<link rel='shortlink' href='https://blog.devart.com/?p=9031' />
<link rel="alternate" type="application/json+oembed" href="https://blog.devart.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.devart.com%2Fincreasing-sqlite-performance.html" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.devart.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.devart.com%2Fincreasing-sqlite-performance.html&#038;format=xml" />

<!-- StarBox - the Author Box for Humans 3.3.1, visit: http://wordpress.org/plugins/starbox/ -->
<!-- /StarBox - the Author Box for Humans -->


<script type='text/javascript' src='https://blog.devart.com/wp-content/plugins/starbox//themes/business/js/frontend.min.js?ver=3.3.1' defer></script>


<link rel="preload" as="font" href="https://blog.devart.com/wp-content/themes/Devart/fonts/glyphicons-halflings-regular.woff2" crossorigin>
<link rel="preload" as="font" href="https://blog.devart.com/wp-content/themes/Devart/fonts/glyphicons-halflings-regular.woff" crossorigin>
<link rel="preload" as="font" href="https://blog.devart.com/wp-content/themes/Devart/fonts/icomoon.ttf?vh4496" crossorigin>
<link rel="preload" as="font" href="https://blog.devart.com/wp-content/themes/Devart/fonts/icomoon.ttf" crossorigin>
<link rel="preload" as="font" href="https://blog.devart.com/wp-content/themes/Devart/fonts/glyphicons-halflings-regular.ttf" crossorigin><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script>
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))
</script></head>
<body>

	<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-N4N25R" 
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

  <header >
  <div id="overlay" class="overlay-page"></div>

<div id="control-area">
			<div class="menu-container">
				<div class="container-fluid menu-container-item">
	<div class="row">
		<nav class="menu clearfix">
			<a href="https://www.devart.com/" title="Devart" class="logo-company"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Devart Logo" data-lazy-src="/images/logo/devart-logo.png"><noscript><img src="/images/logo/devart-logo.png" alt="Devart Logo"></noscript></a>

			<div class="main-menu">
				<ul class="overlay-menu menu-list menu-list_main pull-right">
								<li class="menu-list-item blackout">
									<div class="menu-list-wrap">
										<div class="dropdown-arrow"></div>
										<a class="menu-list-link">Products <i class="fa fa-angle-down"></i></a>
									</div>

									<ul class="menu-dropdown dropdown-menu-full" role="menu">
										<li>
											<div class="container-fluid">
												<div class="row">
													<div class="dropdown-item">
															<div class="col-md-6 col-sm-12 ">
																<div class="dropdown-item__database">
																	<h3 class="dropdown-item__title">
																		<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2036%2037'%3E%3C/svg%3E" height="37" width="36" data-lazy-src="/images/database-tools-icon.svg"><noscript><img src="/images/database-tools-icon.svg" height="37" width="36"></noscript>
																		<span>Database Tools</span>
																	</h3>
																	<p class="dropdown-item__desc">Must-have tools for database development, data analysis, data management, and server administration</p>
																	<nav class="nav-dropdown">
																		<ul class="nav-dropdown-list">
																						<li>
																							<a href="https://www.devart.com/dbforge/sql/"> SQL Server Tools </a>
																						</li>
																						<li>
																							<a href="https://www.devart.com/dbforge/mysql/"> MySQL Tools </a>
																						</li>
																						<li>
																							<a href="https://www.devart.com/dbforge/oracle/"> Oracle Tools </a>
																						</li>
																						<li>
																							<a href="https://www.devart.com/dbforge/postgresql/"> PostgreSQL Tools </a>
																						</li>
																		</ul>
																	</nav>
																</div>
															</div>
															<div class="col-md-6 col-sm-12">
																<div class="dropdown-item__connectivity">
																	<h3 class="dropdown-item__title">																		
																		<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2040%2037'%3E%3C/svg%3E" height="37" width="40" data-lazy-src="/images/data-connectivity-icon.svg"><noscript><img src="/images/data-connectivity-icon.svg" height="37" width="40"></noscript>
																		<span>Data Connectivity</span>
																	</h3>																	
																	<p class="dropdown-item__desc">Wide choice of world-class data connectivity solutions for various data connection technologies and frameworks</p>
																	<nav class="nav-dropdown">
																		<ul class="nav-dropdown-list">
																						<li>
																							<a href="https://www.devart.com/dotconnect/"> ADO.NET Data Providers </a>
																						</li>
																						<li>
																							<a href="https://www.devart.com/odbc/"> ODBC Drivers </a>
																						</li>
																						<li>
																							<a href="https://www.devart.com/ssis/"> SSIS Components </a>
																						</li>
																						<li>
																							<a href="https://www.devart.com/excel-addins/"> Excel Add-ins </a>
																						</li>
																						<li>
																							<a href="https://www.devart.com/dac.html"> Delphi Data Components </a>
																						</li>
																						<li>
																							<a href="https://www.devart.com/dbx/"> dbExpress Drivers </a>
																						</li>
																		</ul>
																	</nav>
																</div>
															</div>
															<div class="col-md-6 col-sm-12">
																<div class="dropdown-item__productivity">
																	<h3 class="dropdown-item__title">																		
																		<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2040%2037'%3E%3C/svg%3E" height="37" width="40" data-lazy-src="/images/productivity-tools-icon.svg"><noscript><img src="/images/productivity-tools-icon.svg" height="37" width="40"></noscript>
																		<span>Productivity Tools</span>
																	</h3>																	
																	<p class="dropdown-item__desc">Tools that help developers to write code, conduct code reviews, compare sources, track the working time, and much more</p>
																	<nav class="nav-dropdown">
																		<ul class="nav-dropdown-list">
																						<li>
																							<a href="https://www.devart.com/productivity-tools.html"> Coding Assistance Tools </a>
																						</li>
																						<li>
																							<a href="https://www.devart.com/orm-solutions.html"> ORM Solutions </a>
																						</li>
																						<li>
																							<a href="https://tmetric.com/" target="_blank"> Time Tracking App </a>
																						</li>
																		</ul>
																	</nav>
																</div>
															</div>
															<div class="col-md-6 col-sm-12">
																<div class="dropdown-item__services">
																	<h3 class="dropdown-item__title">																		
																		<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2042%2037'%3E%3C/svg%3E" height="37" width="42" data-lazy-src="/images/data-services-icon.svg"><noscript><img src="/images/data-services-icon.svg" height="37" width="42"></noscript>
																		<span>Data Services</span>
																	</h3>																	
																	<p class="dropdown-item__desc">All-in-one cloud data platform for no coding data integration, data access, cloud to cloud backup, and management</p>
																	<nav class="nav-dropdown">
																		<ul class="nav-dropdown-list">
																						<li>
																							<a href="https://skyvia.com/data-integration/" target="_blank"> Data Integration Services </a>
																						</li>
																						<li>
																							<a href="https://skyvia.com/backup/" target="_blank"> Cloud to Cloud Backup </a>
																						</li>
																						<li>
																							<a href="https://skyvia.com/query/" target="_blank"> Online SQL Tools </a>
																						</li>
																						<li>
																							<a href="https://skyvia.com/connect/" target="_blank"> OData Server </a>
																						</li>
																		</ul>
																	</nav>
																</div>
															</div>
													</div>
												</div>
											</div>
												<div class="dropdown-footer">
													<div class="container-fluid">
														<div class="row">
															<div class="col-xs-24">
																		<a href="https://www.devart.com/products.html" class="btn button--blue"> All Products </a>
																		<a href="https://www.devart.com/free-products.html" class="btn"> Free Products </a>
															</div>
														</div>
													</div>
												</div>
										</li>
									</ul>
								</li>
								<li class="menu-list-item">
									<a href="https://www.devart.com/products.html" class="menu-list-link">Store</a>
								</li>
								<li class="menu-list-item blackout">
									<div class="menu-list-wrap">
										<div class="dropdown-arrow"></div>
										<a class="menu-list-link">Support <i class="fa fa-angle-down"></i></a>
									</div>

									<ul class="menu-dropdown dropdown-menu-full" role="menu">
										<li>
											<div class="container-fluid">
												<div class="row">
													<div class="dropdown-item">
															<div class="col-md-6 col-sm-12 col-md-offset-6">
																<div class="dropdown-item__tech">
																	<h3 class="dropdown-item__title">																		
																		<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2037%2037'%3E%3C/svg%3E" height="37" width="37" data-lazy-src="/images/tech-support-icon.svg"><noscript><img src="/images/tech-support-icon.svg" height="37" width="37"></noscript>
																		<span>Tech support</span>
																	</h3>																	
																	<p class="dropdown-item__desc">Questions or problems? Our dedicated support teams can answer product related questions.</p>
																	<nav class="nav-dropdown">
																		<ul class="nav-dropdown-list">
																						<li>
																							<a href="https://www.devart.com/company/contactform.html"> Request Support </a>
																						</li>
																						<li>
																							<a href="https://www.devart.com/documentation.html"> Documentation Center </a>
																						</li>
																						<li>
																							<a href="http://forums.devart.com/" target="_blank"> Forums </a>
																						</li>
																		</ul>
																	</nav>
																</div>
															</div>
															<div class="col-md-6 col-sm-12">
																<div class="dropdown-item__sales">
																	<h3 class="dropdown-item__title">																		
																		<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2034%2037'%3E%3C/svg%3E" height="37" width="34" data-lazy-src="/images/sales-support-icon.svg"><noscript><img src="/images/sales-support-icon.svg" height="37" width="34"></noscript>
																		<span>Sales support</span>
																	</h3>																	
																	<p class="dropdown-item__desc">Answers to all common questions that you might have and a bit more.</p>
																	<nav class="nav-dropdown">
																		<ul class="nav-dropdown-list">
																						<li>
																							<a href="https://www.devart.com/orderingfaq.html"> Ordering FAQ </a>
																						</li>
																		</ul>
																	</nav>
																</div>
															</div>
													</div>
												</div>
											</div>
										</li>
									</ul>
								</li>
								<li class="menu-list-item">
									<a href="https://blog.devart.com" class="menu-list-link">Blog</a>
								</li>
								<li class="menu-list-item blackout">
									<div class="menu-list-wrap">
										<div class="dropdown-arrow"></div>
										<a class="menu-list-link">Company <i class="fa fa-angle-down"></i></a>
									</div>

									<ul class="menu-dropdown dropdown-menu-full" role="menu">
										<li>
											<div class="container-fluid">
												<div class="row">
													<div class="dropdown-item">
															<div class="col-md-6 col-sm-12 col-md-offset-3">
																<div class="dropdown-item__about">
																	<h3 class="dropdown-item__title">																		
																		<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2027%2037'%3E%3C/svg%3E" height="37" width="27" data-lazy-src="/images/about-icon.svg"><noscript><img src="/images/about-icon.svg" height="37" width="27"></noscript>
																		<span>About us</span>
																	</h3>																	
																	<p class="dropdown-item__desc">Learn more about the company, people, vision, and history</p>
																	<nav class="nav-dropdown">
																		<ul class="nav-dropdown-list">
																						<li>
																							<a href="https://www.devart.com/company/"> About us </a>
																						</li>
																						<li>
																							<a href="https://www.devart.com/company/customers.html"> Customers </a>
																						</li>
																						<li>
																							<a href="https://www.devart.com/company/partners.html"> Partners </a>
																						</li>
																						<li>
																							<a href="https://www.devart.com/company/resellers.html"> Resellers </a>
																						</li>
																						<li>
																							<a href="https://www.devart.com/company/contact.html"> Contacts </a>
																						</li>
																		</ul>
																	</nav>
																</div>
															</div>
															<div class="col-md-6 col-sm-12">
																<div class="dropdown-item__community">
																	<h3 class="dropdown-item__title">																		
																		<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2031%2037'%3E%3C/svg%3E" height="37" width="31" data-lazy-src="/images/community-icon.svg"><noscript><img src="/images/community-icon.svg" height="37" width="31"></noscript>
																		<span>Resources</span>
																	</h3>																	
																	<p class="dropdown-item__desc">Get updated with the latest news, product releases, special deals, and worldwide events.</p>
																	<nav class="nav-dropdown">
																		<ul class="nav-dropdown-list">
																						<li>
																							<a href="https://www.devart.com/news/"> News </a>
																						</li>
																						<li>
																							<a href="https://www.devart.com/events/2017/"> Events </a>
																						</li>
																		</ul>
																	</nav>
																</div>
															</div>
															<div class="col-md-6 col-sm-12">
																<div class="dropdown-item__resources">
																	<h3 class="dropdown-item__title">																		
																		<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2037%2037'%3E%3C/svg%3E" height="37" width="37" data-lazy-src="/images/resources-icon.svg"><noscript><img src="/images/resources-icon.svg" height="37" width="37"></noscript>
																		<span>Community</span>
																	</h3>																	
																	<p class="dropdown-item__desc">Join our community of technology experts. Learn something new or share your experience with a wide audience.</p>
																	<nav class="nav-dropdown">
																		<ul class="nav-dropdown-list">
																						<li>
																							<a href="http://codingsight.com" target="_blank"> CodingSight </a>
																						</li>
																		</ul>
																	</nav>
																</div>
															</div>
													</div>
												</div>
											</div>
										</li>
									</ul>
								</li>
				</ul>
			</div>

			<ul class="overlay-menu menu-list navbar-right">			
				
				<li class="menu-list-item mobile-menu">
					<div id="nav-mobile">
						<div id="toggle-nav">
							<button class="toggle-btn">
								<span class="toggle"></span>
							</button>
						</div>
						<nav class="nav-slide">
							<div class="mobile-dropdown-menu">
								<ul>
											<li class="has-sub">
												<a href="https://www.devart.com/products.html"><span>Products</span><span class="holder"></span></a>
														<ul>
															<li class="has-sub">
																<a><span>Database Tools</span></a>
																<ul class="sub-sub-menu">
																			<li>
																				<a href="https://www.devart.com/dbforge/sql/"> SQL Server Tools </a>
																			</li>
																			<li>
																				<a href="https://www.devart.com/dbforge/mysql/"> MySQL Tools </a>
																			</li>
																			<li>
																				<a href="https://www.devart.com/dbforge/oracle/"> Oracle Tools </a>
																			</li>
																			<li>
																				<a href="https://www.devart.com/dbforge/postgresql/"> PostgreSQL Tools </a>
																			</li>
																</ul>
															</li>
														</ul>
														<ul>
															<li class="has-sub">
																<a><span>Data Connectivity</span></a>
																<ul class="sub-sub-menu">
																			<li>
																				<a href="https://www.devart.com/dotconnect/"> ADO.NET Data Providers </a>
																			</li>
																			<li>
																				<a href="https://www.devart.com/odbc/"> ODBC Drivers </a>
																			</li>
																			<li>
																				<a href="https://www.devart.com/ssis/"> SSIS Components </a>
																			</li>
																			<li>
																				<a href="https://www.devart.com/excel-addins/"> Excel Add-ins </a>
																			</li>
																			<li>
																				<a href="https://www.devart.com/dac.html"> Delphi Data Components </a>
																			</li>
																			<li>
																				<a href="https://www.devart.com/dbx/"> dbExpress Drivers </a>
																			</li>
																</ul>
															</li>
														</ul>
														<ul>
															<li class="has-sub">
																<a><span>Productivity Tools</span></a>
																<ul class="sub-sub-menu">
																			<li>
																				<a href="https://www.devart.com/productivity-tools.html"> Coding Assistance Tools </a>
																			</li>
																			<li>
																				<a href="https://www.devart.com/orm-solutions.html"> ORM Solutions </a>
																			</li>
																			<li>
																				<a href="https://tmetric.com/" target="_blank"> Time Tracking App </a>
																			</li>
																</ul>
															</li>
														</ul>
														<ul>
															<li class="has-sub">
																<a><span>Data Services</span></a>
																<ul class="sub-sub-menu">
																			<li>
																				<a href="https://skyvia.com/data-integration/" target="_blank"> Data Integration Services </a>
																			</li>
																			<li>
																				<a href="https://skyvia.com/backup/" target="_blank"> Cloud to Cloud Backup </a>
																			</li>
																			<li>
																				<a href="https://skyvia.com/query/" target="_blank"> Online SQL Tools </a>
																			</li>
																			<li>
																				<a href="https://skyvia.com/connect/" target="_blank"> OData Server </a>
																			</li>
																</ul>
															</li>
														</ul>
											</li>
											<li>
												<a href="https://www.devart.com/products.html"><span>Store</span></a>
											</li>
											<li class="has-sub">
												<a href="/company/contactform.html"><span>Support</span><span class="holder"></span></a>
														<ul>
															<li class="has-sub">
																<a><span>Tech support</span></a>
																<ul class="sub-sub-menu">
																			<li>
																				<a href="https://www.devart.com/company/contactform.html"> Request Support </a>
																			</li>
																			<li>
																				<a href="https://www.devart.com/documentation.html"> Documentation Center </a>
																			</li>
																			<li>
																				<a href="http://forums.devart.com/" target="_blank"> Forums </a>
																			</li>
																</ul>
															</li>
														</ul>
														<ul>
															<li class="has-sub">
																<a><span>Sales support</span></a>
																<ul class="sub-sub-menu">
																			<li>
																				<a href="https://www.devart.com/orderingfaq.html"> Ordering FAQ </a>
																			</li>
																</ul>
															</li>
														</ul>
											</li>
											<li>
												<a href="https://blog.devart.com"><span>Blog</span></a>
											</li>
											<li class="has-sub">
												<a href="https://www.devart.com/company/"><span>Company</span><span class="holder"></span></a>
														<ul>
															<li class="has-sub">
																<a><span>About us</span></a>
																<ul class="sub-sub-menu">
																			<li>
																				<a href="https://www.devart.com/company/"> About us </a>
																			</li>
																			<li>
																				<a href="https://www.devart.com/company/customers.html"> Customers </a>
																			</li>
																			<li>
																				<a href="https://www.devart.com/company/partners.html"> Partners </a>
																			</li>
																			<li>
																				<a href="https://www.devart.com/company/resellers.html"> Resellers </a>
																			</li>
																			<li>
																				<a href="https://www.devart.com/company/contact.html"> Contacts </a>
																			</li>
																</ul>
															</li>
														</ul>
														<ul>
															<li class="has-sub">
																<a><span>Resources</span></a>
																<ul class="sub-sub-menu">
																			<li>
																				<a href="https://www.devart.com/news/"> News </a>
																			</li>
																			<li>
																				<a href="https://www.devart.com/events/2017/"> Events </a>
																			</li>
																</ul>
															</li>
														</ul>
														<ul>
															<li class="has-sub">
																<a><span>Community</span></a>
																<ul class="sub-sub-menu">
																			<li>
																				<a href="http://codingsight.com" target="_blank"> CodingSight </a>
																			</li>
																</ul>
															</li>
														</ul>
											</li>
								</ul>
							</div>
						</nav>
					</div>
					<!-- End right menu -->
				</li>
			</ul>
		</nav>
	</div>
</div>
			</div>
		</div>
  </header>


<section class="page-content section-indent">
	<div class="container-fluid">
		<div class="row">
			<div class="col-sm-20">
							</div>

			<div class="col-sm-2 pull-right">
				<a href="https://blog.devart.com/feed" class="rss"></a>
			</div>
		</div>

<div class="row">
<div class="col-sm-17">


    <div id="content" class="narrowcolumn">

    	        
        <div class="post" id="post-9031">
			<div class="category"><a href="https://blog.devart.com/category/products/delphi-dac">Delphi DAC</a></div><div class="category"><a href="https://blog.devart.com/category/how-to">How To</a></div>            <h1 class="single">Increasing SQLite Performance</h1>
            <div class="time-single"><i class="fa fa-clock-o"></i> December 21st, 2015</div>
            <div class="entry">
                <p>One the major issues a developer encounters when using the SQLite DBMS in his applications is its performance issue.</p>
<p>Perhaps, a classic case everyone gets into when using SQLite for the first time is very slow execution of multiple <span class="code"><b>INSERT</b></span>/<span class="code"><b>UPDATE</b></span>/<span class="code"><b>DELETE</b></span> operations. Indeed, sequential executions of not even thousands, but hundreds of INSERTs into a table may take too long.<span id="more-9031"></span>The origin of the issue lies in the specificity of using transactions in SQLite. SQLite starts a transaction automatically every time before any DML statement execution and commits it after execution. Accordingly, when executing multiple consequent statements, a new transaction will be started and committed for each statement.</p>
<p>The solution of this problem is quite simple — the block of DML statements may be enclosed into <span class="code"><b>BEGIN … END</b></span> operators block ( <a href="https://www.sqlite.org/lang_transaction.html">https://www.sqlite.org/lang_transaction.html </a>). In this case, each DML statement won&#8217;t be executed in a separate transaction, but a single transaction will be started before the whole block execution and committed after all modifications.</p>
<p>Such an approach increases SQLite data modification performance by times. See more details about it in the SQLite documentation (<a href="https://www.sqlite.org/faq.html#q19">https://www.sqlite.org/faq.html#q19</a>).</p>
<p>However, this approach is not the only way to increase performance in SQLite. Parameters of the DBMS may also be configured using so-called PRAGMA (<a href="https://www.sqlite.org/pragma.html">https://www.sqlite.org/pragma.html</a>). The fact is that SQLite parameters are oriented not to high performance by default, but to maximum data safety and integrity. Modification of these parameters may increase performance, however, note, that the data corruption risks increase too.</p>
<p>Let’s analyze the impact to inserts performance by different PRAGMAs using <a href="https://www.devart.com/litedac/">LiteDAC</a>.</p>
<p>We will use a test table SPEED_TEST in our project:</p>
<pre lang="SQL">CREATE TABLE SPEED_TEST (
  ID INTEGER,
  F_INTEGER INTEGER,
  F_FLOAT FLOAT,
  F_STRING VARCHAR(250),
  F_DATE DATETIME,
  CONSTRAINT PK_BATCH_TEST PRIMARY KEY (ID)
)
</pre>
<p>In each test, we will delete the database and re-create it, and then insert 10,000 records to the SPEED_TEST table as follows:</p>
<pre lang="Delphi">var
  LiteQuery:  TLiteQuery;
  i: Integer;
  ParamID, ParamF_INTEGER, ParamF_FLOAT, ParamF_STRING, ParamF_DATE: TDAParam;
begin
   ...
  LiteQuery.SQL.Text := 'INSERT INTO SPEED_TEST VALUES (:ID, :F_INTEGER, :F_FLOAT, :F_STRING, :F_DATE)';  ParamID := LiteQuery.Params.ParamByName('ID');
  ParamID.DataType := ftInteger;
  ParamF_INTEGER := LiteQuery.Params.ParamByName('F_INTEGER');
  ParamF_INTEGER.DataType := ftInteger;
  ParamF_FLOAT := LiteQuery.Params.ParamByName('F_FLOAT');
  ParamF_FLOAT.DataType := ftFloat;
  ParamF_STRING := LiteQuery.Params.ParamByName('F_STRING');
  ParamF_STRING.DataType := ftWideString;
  ParamF_DATE := LiteQuery.Params.ParamByName('F_DATE');
  ParamF_DATE.DataType := ftDateTime;

  for i := 0 to 10000 - 1 do begin
    ParamID.AsInteger := i + 1;
    ParamF_INTEGER.AsInteger := i + 5000 + 1;
    ParamF_FLOAT.AsFloat := (i + 1) / 15;
    ParamF_STRING.AsString := 'Values ' + IntToStr(i + 1);
    ParamF_DATE.AsDateTime := Now;
    LiteQuery.Execute;
  end;
  ...
end;
</pre>
<p>We’ll run the test project on 2 platforms: Microsoft Windows 7 x86 and MacOS X 10.9 Mavericks.</p>
<h2>PRAGMA TEMP_STORE</h2>
<p>This parameter allows to specify location of temporary objects in the database: tables, indexes, triggers, views, etc. <span class="code"><b>PRAGMA TEMP_STORE</b></span> accepts 3 values:</p>
<ul>
<li><span class="code"><b>0 | DEFAULT</b></span> — the default value, when location of temporary objects storage is defined by the option, which is set during SQLite compilation;</li>
<li><span class="code"><b>1 | FILE</b></span> — temporary objects are stored in a file (its location depends on the used OS);</li>
<li><span class="code"><b>2 | MEMORY</b></span> — temporary objects are stored in memory.</li>
</ul>
<p>When the <span class="code"><b>TEMP_STORE</b></span> parameter is changed, all the temporary tables, indexes, triggers, views are deleted.</p>
<p><b>Time: sec</b></p>
<table class="doc-table">
<tbody>
<tr>
<th colspan="3">Microsoft Windows 7 x86</th>
</tr>
<tr>
<td>DEFAULT</td>
<td>FILE</td>
<td>MEMORY</td>
</tr>
<tr>
<td>235</td>
<td>225</td>
<td>215</td>
</tr>
</tbody>
</table>
<p>&nbsp;</p>
<table class="doc-table">
<tbody>
<tr>
<th colspan="3">MacOS X 10.9 Mavericks</th>
</tr>
<tr>
<td>DEFAULT</td>
<td>FILE</td>
<td>MEMORY</td>
</tr>
<tr>
<td>34</td>
<td>33</td>
<td>32</td>
</tr>
</tbody>
</table>
<p>According to the retrieved results, making RAM a storage for temporary DB objects increases performance a little.</p>
<h2>PRAGMA JOURNAL_MODE</h2>
<p>The parameter sets the database log working mode (rollback journal file used on transaction processing).</p>
<p><span class="code"><b>PRAGMA JOURNAL_MODE</b></span> accepts the following values:</p>
<ul>
<li><span class="code"><b>DELETE</b></span> (the default value) — in this mode the log file is deleted after transaction is committed.</li>
<li><span class="code"><b>TRUNCATE</b></span> — after transaction is committed, the log file is truncated to 0 size. This works faster than log deleting on a number of platforms, since the catalog containing the log file is not modified at this.</li>
<li><span class="code"><b>PERSIST</b></span> — instead of deleting and truncating, the log file header is filled in with zeros. In this case, the log file size doesn’t change and it can require quite much space. However, such an operation may be executed faster than DELETE or TRUNCATE.</li>
<li><span class="code"><b>MEMORY</b></span> — the rollback journal is kept in RAM and doesn’t use the disk subsystem. Such mode provides more significant performance increase when working with log. However, in case of any failures within a transaction, data in the DB will be corrupted with high probability due to a lack of saved data copy on the disk.</li>
<li><span class="code"><b>OFF</b></span> — not using log. In this mode, transaction rollback is impossible. In case of a crash, the database will be likely corrupted.</li>
</ul>
<p><b>Time: sec</b></p>
<table class="doc-table">
<tbody>
<tr>
<th colspan="5">Microsoft Windows 7 x86</th>
</tr>
<tr>
<td>DELETE</td>
<td>TRUNCATE</td>
<td>PERSIST</td>
<td>MEMORY</td>
<td>OFF</td>
</tr>
<tr>
<td>235</td>
<td>210</td>
<td>220</td>
<td>65</td>
<td>63</td>
</tr>
</tbody>
</table>
<p>&nbsp;</p>
<table class="doc-table">
<tbody>
<tr>
<th colspan="5">MacOS X 10.9 Mavericks</th>
</tr>
<tr>
<td>DELETE</td>
<td>TRUNCATE</td>
<td>PERSIST</td>
<td>MEMORY</td>
<td>OFF</td>
</tr>
<tr>
<td>34</td>
<td>4</td>
<td>3</td>
<td>2</td>
<td>1</td>
</tr>
</tbody>
</table>
<p>Changing this parameter significantly increases performance when inserting data on both platforms. Note, that at using <span class="code"><b>MEMORY</b></span> or <span class="code"><b>OFF</b></span> values, the risk of data loss is maximal too.</p>
<h2>PRAGMA SYNCHRONOUS</h2>
<p>Defines the mode of rollback journal synchronization with the data.</p>
<ul>
<li><span class="code"><b>2 | FULL</b></span> — the default value. SQLite pauses working in critical cases, in order to guarantee 100% data integrity when saving to the database file — even on system crash or power failure. This synchronization mode is absolutely safe, but the most slow.</li>
<li><span class="code"><b>1 | NORMAL</b></span> — SQLite will pause in critical cases as well, but less often in the FULL mode. At this value, there is a (quite small) data corruption possibility. The NORMAL mode is a compromise between reliability and performance.</li>
<li><span class="code"><b>0 | OFF</b></span> — database synchronization is not used. I.e., SQLite takes no breaks when transmitting data to the operating system. Such mode can substantially increase performance. The database will meet the integrity conditions after the SQLite crash, however, data will be corrupted in case of system crash or power off.</li>
</ul>
<p><b>Time: sec</b></p>
<table class="doc-table">
<tbody>
<tr>
<th colspan="3">Microsoft Windows 7 x86</th>
</tr>
<tr>
<td>FULL</td>
<td>NORMAL</td>
<td>OFF</td>
</tr>
<tr>
<td>235</td>
<td>175</td>
<td>43</td>
</tr>
</tbody>
</table>
<p>&nbsp;</p>
<table class="doc-table">
<tbody>
<tr>
<th colspan="3">MacOS X 10.9 Mavericks</th>
</tr>
<tr>
<td>FULL</td>
<td>NORMAL</td>
<td>OFF</td>
</tr>
<tr>
<td>34</td>
<td>32</td>
<td>32</td>
</tr>
</tbody>
</table>
<p>The test demonstrated significant performance increase on Windows. It is highly recommended to speed up performance this way only with assurance of the operating system stability and power quality.</p>
<h2>PRAGMA LOCKING_MODE</h2>
<p>Defines the locking mode.</p>
<ul>
<li><span class="code"><b>NORMAL</b></span> — the default value. The database file is locked at the moment of record reading or writing. After the operation completes, the lock is released.</li>
<li><span class="code"><b>EXCLUSIVE</b></span> — the database file is used in exclusive mode. The number of system calls to implement file operations decreases in this case, which may increase database performance.</li>
</ul>
<p><b>Time: sec</b></p>
<table class="doc-table">
<tbody>
<tr>
<th colspan="2">Microsoft Windows 7 x86</th>
</tr>
<tr>
<td>NORMAL</td>
<td>EXCLUSIVE</td>
</tr>
<tr>
<td>235</td>
<td>155</td>
</tr>
</tbody>
</table>
<p>&nbsp;</p>
<table class="doc-table">
<tbody>
<tr>
<th colspan="2">MacOS X 10.9 Mavericks</th>
</tr>
<tr>
<td>NORMAL</td>
<td>EXCLUSIVE</td>
</tr>
<tr>
<td>34</td>
<td>3</td>
</tr>
</tbody>
</table>
<p>The most secure approach to increase performance. Though, <span class="code"><b>EXCLUSIVE MODE</b></span> allows the database to serve only one connection.</p>
<h2>PRAGMA CACHE_SIZE</h2>
<p>Defines the number of pages from the database file for storing in RAM, i.e., the cache size. Increasing this parameter may increase performance of the database on high load, since the greater its value is, the more modifications a session can perform before retrieving exclusive lock.</p>
<p><b>Time: sec</b></p>
<table class="doc-table">
<tbody>
<tr>
<th colspan="7">Microsoft Windows 7 x86</th>
</tr>
<tr>
<td>0</td>
<td>500</td>
<td>1000</td>
<td>2000</td>
<td>4000</td>
<td>8000</td>
<td>10000</td>
</tr>
<tr>
<td>222</td>
<td>185</td>
<td>230</td>
<td>230</td>
<td>230</td>
<td>230</td>
<td>250</td>
</tr>
</tbody>
</table>
<p>&nbsp;</p>
<table class="doc-table">
<tbody>
<tr>
<th colspan="7">MacOS X 10.9 Mavericks</th>
</tr>
<tr>
<td>0</td>
<td>500</td>
<td>1000</td>
<td>2000</td>
<td>4000</td>
<td>8000</td>
<td>10000</td>
</tr>
<tr>
<td>&#8211;</td>
<td>34</td>
<td>34</td>
<td>34</td>
<td>34</td>
<td>34</td>
<td>34</td>
</tr>
</tbody>
</table>
<p>Performance increase is observed only on Windows. Changing this parameter is almost secure, yet the performance growth is minor.</p>
<h2>PRAGMA PAGE_SIZE</h2>
<p>Defines the database page size.</p>
<p>The page size is set by default depending on some computer and OS specifications. They include disk sector size and the used encoding. SQLite supports page size range from 512 to 65536 bytes.</p>
<p><b>Time: sec</b></p>
<table class="doc-table">
<tbody>
<tr>
<th colspan="8">Windows 7 x86</th>
</tr>
<tr>
<td>512</td>
<td>1024</td>
<td>2048</td>
<td>4096</td>
<td>8192</td>
<td>16384</td>
<td>32768</td>
<td>65535</td>
</tr>
<tr>
<td>240</td>
<td>235</td>
<td>227</td>
<td>225</td>
<td>255</td>
<td>295</td>
<td>450</td>
<td>295</td>
</tr>
</tbody>
</table>
<p>&nbsp;</p>
<table class="doc-table">
<tbody>
<tr>
<th colspan="8">MacOS X 10.9 Mavericks</th>
</tr>
<tr>
<td>512</td>
<td>1024</td>
<td>2048</td>
<td>4096</td>
<td>8192</td>
<td>16384</td>
<td>32768</td>
<td>65535</td>
</tr>
<tr>
<td>34</td>
<td>34</td>
<td>33</td>
<td>33</td>
<td>34</td>
<td>40</td>
<td>50</td>
<td>65</td>
</tr>
</tbody>
</table>
<p>Like the previous parameter, <span class="code"><b>PRAGMA PAGE_SIZE</b></span> is almost safe with respect to risk of data corruption, however, tuning of this parameter doesn’t lead to significant performance increase and requires search for values depending on the used sector size.</p>
<h2>Summary</h2>
<ol>
<li>There are ways to increase SQLite data insert performance in addition to using transactions.</li>
<li>Usage of PRAGMA may significantly increase performance of SQLite.</li>
<li>SQLite default settings don’t provide optimal performance, yet guarantee absolute data integrity and safety.</li>
<li>Changing SQLite parameter values in favor of performance increases the risk of data corruption.</li>
<li>Values of some parameters (<span class="code"><b>PRAGMA PAGE_SIZE</b></span>, <span class="code"><b>PRAGMA CACHE_SIZE</b></span>) should be found depending on specifications of the used environment.</li>
</ol>

                         <div class="abh_box abh_box_down abh_box_business"><ul class="abh_tabs"> <li class="abh_about abh_active"><a href="#abh_about">Author</a></li> <li class="abh_posts"><a href="#abh_posts">Recent Posts</a></li></ul><div class="abh_tab_content"><section class="vcard author abh_about_tab abh_tab" itemscope itemprop="author" itemtype="http://schema.org/Person" style="display:block"><div class="abh_image" itemscope itemtype="http://schema.org/ImageObject"><a href = "https://blog.devart.com/author/dac" class="url" title = "DAC Team" > <img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20250%20250'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=500&#038;d=mm&#038;r=g 2x' class='avatar avatar-250 photo' height='250' width='250' data-lazy-src="https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=250&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=250&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=500&#038;d=mm&#038;r=g 2x' class='avatar avatar-250 photo' height='250' width='250' /></noscript></a > </div><div class="abh_social"> </div><div class="abh_text"><h3 class="fn name" itemprop="name" ><a href="https://blog.devart.com/author/dac" class="url">DAC Team</a></h3><div class="abh_job" ></div><div class="description note abh_description" itemprop="description" ></div></div> </section><section class="abh_posts_tab abh_tab" ><div class="abh_image"><a href="https://blog.devart.com/author/dac" class="url" title="DAC Team"><img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20250%20250'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=500&#038;d=mm&#038;r=g 2x' class='avatar avatar-250 photo' height='250' width='250' data-lazy-src="https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=250&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=250&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=500&#038;d=mm&#038;r=g 2x' class='avatar avatar-250 photo' height='250' width='250' /></noscript></a></div><div class="abh_social"> </div><div class="abh_text"><h4 >Latest posts by DAC Team <span class="abh_allposts">(<a href="https://blog.devart.com/author/dac">see all</a>)</span></h4><div class="abh_description note" ><ul>				<li>					<a href="https://blog.devart.com/new-versions-odbc-drivers-salesforce-zoho-dynamics.html">New Versions of ODBC Drivers for Salesforce, Dynamics 365, and Zoho CRM</a><span> - April 23, 2021</span>				</li>				<li>					<a href="https://blog.devart.com/securebridge-components-for-ssl-server.html">New in SecureBridge: RAD Studio 10.4.2 and TLS/SSL Server Component</a><span> - March 30, 2021</span>				</li>				<li>					<a href="https://blog.devart.com/delphi-dac-support-for-rad-studio-10-4-2.html">New in Delphi DAC: Support for RAD Studio 10.4.2 and Multiple Performance Improvements</a><span> - March 3, 2021</span>				</li></ul></div></div> </section></div> </div><p class="postmetadata"><i class="fa fa-tag"></i><a href="https://blog.devart.com/tag/litedac" rel="tag">litedac</a>, <a href="https://blog.devart.com/tag/performance" rel="tag">performance</a>, <a href="https://blog.devart.com/tag/sqlite" rel="tag">sqlite</a>, <a href="https://blog.devart.com/tag/tips-and-tricks-2" rel="tag">tips and tricks</a> </p>
<div class="sample-posts">

<div class="h3zag">See also</div>


<li><a href="https://blog.devart.com/is-unpivot-the-best-way-for-converting-columns-into-rows.html" rel="bookmark" title="Is UNPIVOT the best way for converting columns into rows?">Is UNPIVOT the best way for converting columns into rows?</a></li>


<li><a href="https://blog.devart.com/entity-framework-6-3-and-net-core-3-support.html" rel="bookmark" title="Entity Framework 6.3 and .NET Core 3 Support">Entity Framework 6.3 and .NET Core 3 Support</a></li>


<li><a href="https://blog.devart.com/fast-and-simple-database-application-development-and-deployment-to-linux-in-rad-studio.html" rel="bookmark" title="Fast and Simple Database App Development and Deployment to Linux in RAD Studio">Fast and Simple Database App Development and Deployment to Linux in RAD Studio</a></li>


<li><a href="https://blog.devart.com/sql-server-execution-plans.html" rel="bookmark" title="SQL Server Execution Plans">SQL Server Execution Plans</a></li>


<li><a href="https://blog.devart.com/what-is-faster-inside-stream-aggregate-hash-match.html" rel="bookmark" title="What is faster inside SUM &amp; AVG: 0 or NULL?">What is faster inside SUM &amp; AVG: 0 or NULL?</a></li>


</div>
            </div>
        </div>
        

    
<!-- You can start editing here. -->

	<h3 id="comments">8 Responses to &#8220;Increasing SQLite Performance&#8221;</h3>

	<ol class="commentlist">

	
		<li class="alt" id="comment-368999">
			<img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2032%2032'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/9eeb356f6a5f28a74b9f7e34c8753562?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' data-lazy-src="https://secure.gravatar.com/avatar/9eeb356f6a5f28a74b9f7e34c8753562?s=32&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/9eeb356f6a5f28a74b9f7e34c8753562?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/9eeb356f6a5f28a74b9f7e34c8753562?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /></noscript>			<cite>Sommer</cite> Says:
						<br />

			<small class="commentmetadata"><a href="#comment-368999" title="">November 26th, 2016 at 11:25 pm</a> </small>

			<p>Hello &#8211; nice article. But when I see the measured values I have one question: Why is windows so horrible slow? Can this be fixed or relies this on the poor performance of ntfs?</p>

		</li>

	
	
		<li id="comment-370671">
			<img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2032%2032'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/44fa5206cc2ddfdd31f68fd8dc41b2b7?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' data-lazy-src="https://secure.gravatar.com/avatar/44fa5206cc2ddfdd31f68fd8dc41b2b7?s=32&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/44fa5206cc2ddfdd31f68fd8dc41b2b7?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/44fa5206cc2ddfdd31f68fd8dc41b2b7?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /></noscript>			<cite>SCipV</cite> Says:
						<br />

			<small class="commentmetadata"><a href="#comment-370671" title="">January 3rd, 2017 at 7:19 pm</a> </small>

			<p>What software did you used to execute that piece of sql?</p>

		</li>

	
	
		<li class="alt" id="comment-371908">
			<img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2032%2032'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' data-lazy-src="https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=32&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /></noscript>			<cite>DAC Team</cite> Says:
						<br />

			<small class="commentmetadata"><a href="#comment-371908" title="">February 14th, 2017 at 3:33 pm</a> </small>

			<p>Hello, Sommer!<br />
This article is not intended to compare SQLite performance on Microsoft Windows and MacOS X platforms, but to show SQLite certain settings impact when using a particular platform. In addition, in our test environment computers with Microsoft Windows and MacOS X have completely different hardware implementation.<br />
Therefore, it is appropriate not to compare Microsoft Windows and MacOS X characteristics, but to compare characteristics of the same platform with different settings.</p>

		</li>

	
	
		<li id="comment-371909">
			<img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2032%2032'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' data-lazy-src="https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=32&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /></noscript>			<cite>DAC Team</cite> Says:
						<br />

			<small class="commentmetadata"><a href="#comment-371909" title="">February 14th, 2017 at 3:36 pm</a> </small>

			<p>Hello, SCipV!<br />
When writing this article to work with SQLite we used our LiteDAC components &#8211; <a href="https://www.devart.com/litedac/" rel="nofollow">https://www.devart.com/litedac/</a></p>

		</li>

	
	
		<li class="alt" id="comment-374221">
			<img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2032%2032'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/6619a17f48abebf8d88cd70c022d396f?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' data-lazy-src="https://secure.gravatar.com/avatar/6619a17f48abebf8d88cd70c022d396f?s=32&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/6619a17f48abebf8d88cd70c022d396f?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/6619a17f48abebf8d88cd70c022d396f?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /></noscript>			<cite>G</cite> Says:
						<br />

			<small class="commentmetadata"><a href="#comment-374221" title="">May 3rd, 2017 at 12:45 am</a> </small>

			<p>Nice article, thanks!</p>
<p>One question: which of these parameter will still affect data loading done using the &#8220;.import&#8221; command within the sqlite3?<br />
For instance, I am assuming that blocking of DML statements is already done when using &#8220;.import&#8221;.<br />
But does setting &#8220;LOCKING_MODE&#8221; make any difference?</p>

		</li>

	
	
		<li id="comment-374251">
			<img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2032%2032'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' data-lazy-src="https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=32&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /></noscript>			<cite>DAC Team</cite> Says:
						<br />

			<small class="commentmetadata"><a href="#comment-374251" title="">May 4th, 2017 at 5:09 pm</a> </small>

			<p>Hello, G!<br />
You mean the option .import Command Line Shell For SQLite. In this article, we considered the influence of SQLite settings using PRAGMA commands on work performance with data. Possibly, Command Line Shell For SQLite implements the data import operation with these settings. Or these settings can be applied to SQLite DB when using this utility. You can find the answers to these questions by referring to this utility documentation or test its work by yourself.</p>

		</li>

	
	
		<li class="alt" id="comment-394298">
			<img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2032%2032'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/a6a4361fcb7c122787c60a9b0b4011db?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' data-lazy-src="https://secure.gravatar.com/avatar/a6a4361fcb7c122787c60a9b0b4011db?s=32&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/a6a4361fcb7c122787c60a9b0b4011db?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a6a4361fcb7c122787c60a9b0b4011db?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /></noscript>			<cite>Paresh</cite> Says:
						<br />

			<small class="commentmetadata"><a href="#comment-394298" title="">November 9th, 2018 at 11:20 am</a> </small>

			<p>Hi Thanks for the article<br />
i have one issue that while using WAL PRAGMA_Mode the no of .shm files are going out of bounds.how can i limit it?</p>

		</li>

	
	
		<li id="comment-394303">
			<img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2032%2032'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' data-lazy-src="https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=32&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/742b60c152006a081e0fdae11f51fffe?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /></noscript>			<cite>DAC Team</cite> Says:
						<br />

			<small class="commentmetadata"><a href="#comment-394303" title="">November 9th, 2018 at 3:01 pm</a> </small>

			<p>Hello, Paresh!<br />
Working with &#8220;X-wal&#8221; and &#8220;X-shm&#8221; files in WAL-mode fully depends on the work of the SQLite Engine itself and we cannot influence this behavior in our access components for this DB.<br />
Try contacting SQLite technical support with this question or find the answer at one of the specialized forums.</p>

		</li>

	
	
	</ol>

 


<div class="h3zag">Leave a Comment</div>


<form action="https://blog.devart.com/wp-comments-post.php" method="post" id="commentform">

<div class="row">
	<div class="col-md-12">
		<div class="comment-label">
			<label for="author">Name <span class="required">*</span></label>
		</div>
		<div>
			<input type="text" name="author" id="author" value="" size="22" tabindex="1" aria-required='true' />
		</div>
	</div>
	<div class="col-md-12">
		<div class="comment-label">
			<label for="email">Mail <span class="clarification">(will not be published)</span> <span class="required">*</span></label>
		</div>
		<div><input type="text" name="email" id="email" value="" size="22" tabindex="2" aria-required='true' /></div>
	</div>
</div>

<!--<p><small><strong>XHTML:</strong> You can use these tags: <code>&lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; </code></small></p>-->

<p>
<div class="comment-label comment-label--message">
	<label for="email">Message <span class="required">*</span></label>
</div>
<textarea name="comment" id="comment" cols="100%" rows="5" tabindex="4"></textarea>
</p>

<p class="comment-button"><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" class="btn button--blue" />
<input type="hidden" name="comment_post_ID" value="9031" />
</p>
<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="3c44065b9a" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="232"/></p>
</form>



    
    </div>

﻿<hr />
</div> 
<div class="col-sm-6 col-sm-offset-1">
	<div class="sidebar-wrap">
		<li id="search-2" class="widget widget_search"><form class="navbar-form" role="search" method="get" id="searchform" action="https://blog.devart.com">
	<div class="input-group">
		<input type="text" class="form-control" placeholder="Type text to search" value="" name="s" id="s" />
		<div class="input-group-btn">
			<button class="btn btn-default" type="submit">
				<i class="glyphicon glyphicon-search"></i>
			</button>
		</div>
	</div>
</form>
</li><li id="text-2" class="widget widget_text"><h2 class="widgettitle">Topics</h2>			<div class="textwidget"><ul class="products-cat">
<li class="cat-item"><a href="/category/whats-new">What’s New</a></li>
<li class="cat-item"><a href="/category/product-release">Product Release</a></li>
<li class="cat-item"><a href="/category/events">Events</a></li>
<li class="cat-item"><a href="/category/how-to">How To</a></li>
</ul>
</div>
		</li>		</ul>
	</div>
	<div class="sidebar-wrap">
		<ul class="products-cat">
			<li class="widget_text">
				<h2 class="widgettitle"><span>Products</span></h2>
			</li>
				<li class="cat-item cat-item-321"><a href="https://blog.devart.com/category/products/ado-net-data-providers">ADO.NET Data Providers</a>
</li>
	<li class="cat-item cat-item-316"><a href="https://blog.devart.com/category/products/delphi-dac">Delphi DAC</a>
</li>
	<li class="cat-item cat-item-319"><a href="https://blog.devart.com/category/products/excel-addins">Excel Add-ins</a>
</li>
	<li class="cat-item cat-item-232"><a href="https://blog.devart.com/category/products/mysql-tools">MySQL Tools</a>
</li>
	<li class="cat-item cat-item-317"><a href="https://blog.devart.com/category/products/odbc-drivers">ODBC Drivers</a>
</li>
	<li class="cat-item cat-item-230"><a href="https://blog.devart.com/category/products/oracle-tools">Oracle Tools</a>
</li>
	<li class="cat-item cat-item-320"><a href="https://blog.devart.com/category/products/orm-solutions">ORM Solutions</a>
</li>
	<li class="cat-item cat-item-233"><a href="https://blog.devart.com/category/products/postgresql-tools">PostgreSQL Tools</a>
</li>
	<li class="cat-item cat-item-315"><a href="https://blog.devart.com/category/products/productivity-tools">Productivity Tools</a>
</li>
	<li class="cat-item cat-item-231"><a href="https://blog.devart.com/category/products/sql-server-tools">SQL Server Tools</a>
</li>
	<li class="cat-item cat-item-318"><a href="https://blog.devart.com/category/products/ssis-components">SSIS Components</a>
</li>
		</ul>
	</div>	
	<div class="sidebar-wrap">
		<ul class="products-cat">
			<li class="widget_text">
				<h2 class="widgettitle"><span>Popular post</span></h2>
			</li>
						<li class="cat-item">
				<a title="Is UNPIVOT the best way for converting columns into rows?" href="https://blog.devart.com/is-unpivot-the-best-way-for-converting-columns-into-rows.html" class="popular-post-title">Is UNPIVOT the best way for converting columns into rows?</a>
				<div class="popular-post-date"><i class="fa fa-clock-o"></i> June 15th, 2020</div>
			</li>
						<li class="cat-item">
				<a title="Find invalid objects in your databases" href="https://blog.devart.com/find-invalid-objects-in-your-databases.html" class="popular-post-title">Find invalid objects in your databases</a>
				<div class="popular-post-date"><i class="fa fa-clock-o"></i> June 6th, 2020</div>
			</li>
						<li class="cat-item">
				<a title="Increasing SQLite Performance" href="https://blog.devart.com/increasing-sqlite-performance.html" class="popular-post-title">Increasing SQLite Performance</a>
				<div class="popular-post-date"><i class="fa fa-clock-o"></i> December 21st, 2015</div>
			</li>
					</ul>
	</div>
</div>
<!-- Gorgeous design by Michael Heilemann - http://binarybonsai.com/kubrick/ -->

</div>
        </div>
    </section>  
<script type='text/javascript'>
/* <![CDATA[ */
var codePrettifyLoaderBaseUrl = "https:\/\/blog.devart.com\/wp-content\/plugins\/code-prettify\/prettify";
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.devart.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0' defer></script>
<script type='text/javascript' src='https://blog.devart.com/wp-includes/js/wp-embed.min.js?ver=5.2.3' defer></script>
<script async="async" type='text/javascript' src='https://blog.devart.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://blog.devart.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img loading="lazy" data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.dataset.query.length?'':'&'+this.dataset.query;e.setAttribute("src",t.replace("ID",this.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script>

    <!-- Start Subscribe Section -->
    <div class="footer-wrap">
        
        <!-- End Subscribe Section -->
        <!-- Start Footer -->
        <footer class="s-footer">
            <div class="container-fluid">
                <div class="row">
                    <div class="col-md-24">
                        <div class="footer">
                            <div class="footer-logo">
                                <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Devart" data-lazy-src="/images/logo/devart-logo.png" /><noscript><img src="/images/logo/devart-logo.png" alt="Devart" /></noscript>
                                <div class="footer-desc">Founded in 1997, Devart is currently one of the leading developers of database management software, ALM solutions and data providers for most popular database servers.</div>
                                <nav class="social">
                                    <ul class="footer-list">
                                        <li class="social-item">
                                            <a href="https://www.facebook.com/DevartSoftware" target="_blank" class="social-link social-link--facebook">
                                                <svg class="di facebook-footer">
                                                    <use xlink:href="#facebook"></use>
                                                </svg>
                                            </a>
                                        </li>
                                        <li class="social-item">
                                            <a href="https://twitter.com/DevartSoftware" target="_blank" class="social-link social-link--twitter">
                                                <svg class="di twitter-footer">
                                                    <use xlink:href="#twitter"></use>
                                                </svg>
                                            </a>
                                        </li>
                                        <li class="social-item">
                                            <a href="https://www.linkedin.com/company/devart" target="_blank" class="social-link social-link--in">
                                                <svg class="di linkedin">
                                                    <use xlink:href="#linkedin"></use>
                                                </svg>
                                            </a>
                                        </li>
                                        <li class="social-item">
                                            <a href="https://www.youtube.com/user/DevartSoftware" target="_blank" class="social-link social-link--youtube">
                                                <svg class="di youtube-play">
                                                    <use xlink:href="#youtube-play"></use>
                                                </svg>
                                            </a>
                                        </li>
                                    </ul>
                                </nav>
                            </div>

                            <div class="footer-item footer-products">
                                <h3>Products</h3>
                                <div class="footer-list-wrap">
                                    <ul class="footer-list">
                                        <li class="footer-list-item"><a href="https://www.devart.com/dbforge/sql/" class="footer-list-link">SQL Server Tools</a></li>
                                        <li class="footer-list-item"><a href="https://www.devart.com/dbforge/mysql/" class="footer-list-link">MySQL Tools</a></li>
                                        <li class="footer-list-item"><a href="https://www.devart.com/dbforge/oracle/" class="footer-list-link">Oracle Tools</a></li>
                                        <li class="footer-list-item"><a href="https://www.devart.com/dbforge/postgresql/" class="footer-list-link">PostgreSQL Tools</a></li>
                                        <li class="footer-list-item"><a href="https://www.devart.com/productivity-tools.html" class="footer-list-link">Productivity Tools</a></li>
                                        <li class="footer-list-item"><a href="https://skyvia.com/" class="footer-list-link">Skyvia</a></li>
                                        <li class="footer-list-item"><a href="https://www.devart.com/discontinued.html" class="footer-list-link">Discontinued Products</a></li>
                                    </ul>
                                    <ul class="footer-list">
                                        <li class="footer-list-item"><a href="https://www.devart.com/dotconnect/" class="footer-list-link">ADO.NET Data Providers</a></li>
                                        <li class="footer-list-item"><a href="https://www.devart.com/orm-solutions.html" class="footer-list-link">ORM Solutions</a></li>
                                        <li class="footer-list-item"><a href="https://www.devart.com/odbc/" class="footer-list-link">ODBC Drivers</a></li>
                                        <li class="footer-list-item"><a href="https://www.devart.com/ssis/" class="footer-list-link">SSIS Components</a></li>
                                        <li class="footer-list-item"><a href="https://www.devart.com/excel-addins/" class="footer-list-link">Excel Add-ins</a></li>
                                        <li class="footer-list-item"><a href="https://www.devart.com/dac.html" class="footer-list-link">Delphi Data Access Components</a></li>
                                        <li class="footer-list-item"><a href="https://www.devart.com/dbx/" class="footer-list-link">dbExpress Drivers</a></li>
                                    </ul>
                                </div>
                            </div>

                            <div class="footer-item footer-support">
                                <h3>Support</h3>
                                <ul class="footer-list">
                                    <li class="footer-list-item"><a href="https://www.devart.com/company/contactform.html" class="footer-list-link">Submit Request</a></li>
                                    <li class="footer-list-item"><a href="https://forums.devart.com/" class="footer-list-link">View Forums</a></li>
                                    <li class="footer-list-item"><a href="https://docs.devart.com/" class="footer-list-link">Documentation Center</a></li>
                                    <li class="footer-list-item"><a href="https://www.devart.com/orderingfaq.html" class="footer-list-link">Ordering FAQs</a></li>
                                    <li class="footer-list-item"><a href="https://www.devart.com/discount-programs.html" class="footer-list-link">Discount Programs</a></li>
                                    <li class="footer-list-item"><a href="https://www.devart.com/using-website/" class="footer-list-link">Using Website</a></li>
                                </ul>
                            </div>

                            <div class="footer-item footer-company">
                                <h3>Company</h3>
                                <div class="footer-list-wrap">
                                    <ul class="footer-list">
                                        <li class="footer-list-item"><a href="https://www.devart.com/company/" class="footer-list-link">About Us</a></li>
                                        <li class="footer-list-item"><a href="https://www.devart.com/news/" class="footer-list-link">Archive News</a></li>
                                        <li class="footer-list-item"><a href="https://www.devart.com/company/contact.html" class="footer-list-link">Contacts</a></li>
                                        <li class="footer-list-item"><a href="https://www.devart.com/company/contactform.html" class="footer-list-link">Contact Us</a></li>
                                        <li class="footer-list-item"><a href="https://www.devart.com/success-story/" class="footer-list-link">Success Stories</a></li>
                                    </ul>
                                    <ul class="footer-list">
                                        <li class="footer-list-item"><a href="https://www.devart.com/events/" class="footer-list-link">Events</a></li>
                                        <li class="footer-list-item"><a href="https://www.devart.com/company/customers.html" class="footer-list-link">Customers</a></li>
                                        <li class="footer-list-item"><a href="https://www.devart.com/company/partners.html" class="footer-list-link">Partners</a></li>
                                        <li class="footer-list-item"><a href="https://www.devart.com/company/resellers.html" class="footer-list-link">Resellers</a></li>
                                    </ul>
                                </div>
                            </div>
                        </div> <!-- End Footer Wrap -->
                        <div class="footer-bottom">
                            <div class="footer-partners">
                                <ul class="footer-list">
                                    <li class="footer-list-item"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Microsoft Partner" data-lazy-src="/images/footer/microsoft-partner.png" /><noscript><img src="/images/footer/microsoft-partner.png" alt="Microsoft Partner" /></noscript></li>
                                    <li class="footer-list-item"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Oracle" data-lazy-src="/images/footer/oracle.png" /><noscript><img src="/images/footer/oracle.png" alt="Oracle" /></noscript></li>
                                    <li class="footer-list-item"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Embarcadero" data-lazy-src="/images/footer/embarcadero.png" /><noscript><img src="/images/footer/embarcadero.png" alt="Embarcadero" /></noscript></li>
                                    <li class="footer-list-item"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Visual Studio" data-lazy-src="/images/footer/visual-studio.png" /><noscript><img src="/images/footer/visual-studio.png" alt="Visual Studio" /></noscript></li>
                                </ul>
                            </div>
                        </div>
                    </div> <!-- End col-md-12 -->
                </div> <!-- End row -->
            </div> <!-- End Container -->
            <div class="sub-footer bounce">
                <div class="container-fluid">
                    <div class="row">
                        <div class="col-sm-8 col-xs-24">
                            <div class="footer-copy">&copy; 1997 - 2019 Devart. All rights reserved.</div>
                        </div>
                        <div class="col-sm-8 col-xs-24 text-center sub-footer-link">
                            <a href="https://devart.com/using-website/privacy-policy.html">Privacy &amp; Security</a> | <a href="https://devart.com/using-website/terms-of-use.html">Terms of Use</a>
                        </div>
                        <div class="col-sm-8 col-xs-24 text-right">
                            <div class="btn-up pull-right" title="Up">Back on Top <i class="arrow-up"></i></div>
                        </div>
                    </div>
                </div>
            </div>
        </footer>
        <!-- End Footer -->
    </div>

<script type="text/javascript" src="https://ajax.aspnetcdn.com/ajax/jquery/jquery-2.2.0.min.js"></script>
<script type="text/javascript" src="https://ajax.aspnetcdn.com/ajax/bootstrap/3.3.6/bootstrap.min.js" defer></script>
<script type="text/javascript" src="https://www.devart.com/lib/owl.carousel/dist/owl.carousel.min.js" defer></script>

<script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/fancybox/3.1.20/jquery.fancybox.js"></script> 
<script type="text/javascript" src="https://www.devart.com/js/site.min.js"></script>

<script type="text/javascript">window.addEventListener('DOMContentLoaded', function() {
	$(document).ready(function () {
		$('a[href$="jpg"], a[href$="png"], a[href$="jpeg"]').fancybox();
	});
});</script>
 
<!-- SyntaxHighlighter JavaScript -->
<script type="text/javascript" src="https://blog.devart.com/wp-content/themes/Devart/js/syntax-highlighter/XRegExp.js" defer></script>
<script type="text/javascript" src="https://blog.devart.com/wp-content/themes/Devart/js/syntax-highlighter/shCore.js" defer></script>
<script type="text/javascript" src="https://blog.devart.com/wp-content/themes/Devart/js/syntax-highlighter/shBrushDelphi.js" defer></script>
<script type="text/javascript" src="https://blog.devart.com/wp-content/themes/Devart/js/syntax-highlighter/shBrushJava.js" defer></script>
<script type="text/javascript" src="https://blog.devart.com/wp-content/themes/Devart/js/syntax-highlighter/shBrushXml.js" defer></script>
<script type="text/javascript" src="https://blog.devart.com/wp-content/themes/Devart/js/syntax-highlighter/shBrushSql.js" defer></script>
<script type="text/javascript" src="https://blog.devart.com/wp-content/themes/Devart/js/syntax-highlighter/shBrushCSharp.js" defer></script>
<script type="text/javascript" src="https://blog.devart.com/wp-content/themes/Devart/js/syntax-highlighter/shBrushVb.js" defer></script>
<script type="text/javascript" src="https://blog.devart.com/wp-content/themes/Devart/js/tagsColor.js" defer></script>

<script type="text/javascript"> 
	SyntaxHighlighter.highlight(); 
</script>
<svg xmlns="http://www.w3.org/2000/svg" style="display:none;">
    <symbol id="arrow-down" viewBox="0 0 14 8">
        <path d="M12.79 0L14 1.4 7.008 8 0 1.384 1.224 0l5.784 5.486L12.79 0z" />
    </symbol>
    <symbol id="avatar" viewBox="0 0 60 60">
        <path d="M32.1 59.9c.4 0 .7 0 1.1-.1.2 0 .4-.1.6-.1.3 0 .6-.1 1-.1.2 0 .4-.1.6-.1.3-.1.6-.1.9-.2.2 0 .4-.1.6-.1.3-.1.6-.1.9-.2.2-.1.4-.1.6-.2l.9-.3c.2-.1.4-.1.6-.2l.9-.3c.2-.1.4-.1.5-.2.3-.1.6-.2.9-.4.2-.1.3-.1.5-.2.3-.1.6-.3.9-.4.1-.1.3-.1.4-.2.3-.2.6-.3.9-.5.1-.1.3-.1.4-.2.3-.2.7-.4 1-.6.1-.1.2-.1.3-.2.4-.2.7-.5 1.1-.7.1 0 .1-.1.2-.1 13.3-9.8 16.2-28.6 6.4-41.9C44.5-.9 25.5-4 12.2 5.8-1.1 15.6-4 34.5 5.8 47.8c.9 1.2 1.9 2.4 3 3.5l.3.3.8.8c.1.1.2.2.4.3.3.2.5.4.8.6.1.1.3.2.4.3.2.2.5.4.7.6.2.1.3.2.5.3.2.2.5.3.7.5.2.1.3.2.5.3.2.2.5.3.8.5.2.1.4.2.5.3.3.1.5.3.8.4l.6.3c.3.1.5.3.8.4l.6.3c.3.1.5.2.8.3.2.1.4.2.6.2.3.1.5.2.8.3.2.1.4.1.6.2.3.1.6.2.8.2.2.1.4.1.6.2.3.1.6.1.9.2.2.1.4.1.6.1.3.1.6.1.9.2.2 0 .4.1.6.1.3 0 .6.1.9.1.2 0 .4.1.6.1.3 0 .7.1 1 .1h3.7c.4.1.5.1.7.1zM30 1.7c15.6 0 28.3 12.6 28.3 28.2 0 7.1-2.7 14-7.5 19.2-3.6-1.8-7.4-3.3-11.2-4.7-2.4-.7-2.6-3.7-2.6-3.7-.2-2.5.7-3.6.7-3.6 1.3-1.6 2-3.6 1.9-5.6 1.7.2 1.5-1.3 1.5-2.3 0-.9.4-1.1.8-2.2.7-2-1.1-2-1.1-2 2.6-8.9-2.1-9.6-2.1-9.6-2.9-6-9-6.1-12.7-5.1-3.8 1-6.7 4.2-7.3 8.1-.2 2.2 0 4.5.7 6.7-1.4-.1-1.4 1.5-.6 2.6.4.6.7 1.3.7 2.1.1 2.5 1.6 1.9 1.6 1.9 0 2.1.7 4.1 2 5.8.9 1.4.7 1.6.4 3.7-.3 1.5-1.3 2.7-2.7 3.3 0 0-2.3.9-7.1 2.7-1.5.6-3 1.3-4.4 2.1C-1.3 37.9-.7 20 10.7 9.4c5.2-5 12.1-7.7 19.3-7.7z" />
    </symbol>
    <symbol id="search" viewBox="0 0 17.997 18.001">
        <path d="M2.157 7.3a5.199 5.199 0 1 1 5.198 5.157A5.184 5.184 0 0 1 2.157 7.3zm15.84 8.935l-4.69-4.653A7.22 7.22 0 0 0 14.711 7.3 7.356 7.356 0 0 0 0 7.3a7.364 7.364 0 0 0 11.503 6.024l4.715 4.678z" />
    </symbol>
    <symbol id="cart">
        <path d="M7.627 12h12.597l-.84 2H6.146L2.673 2H.743L0 0h4.195zm1.537-2L7.188 3H24l-2.938 7zm1.336 5A1.5 1.5 0 1 1 9 16.5a1.5 1.5 0 0 1 1.5-1.5zm3.5 1.5a1.5 1.5 0 1 0 1.5-1.5 1.5 1.5 0 0 0-1.5 1.5z" />
    </symbol>
    <symbol id="facebook" viewBox="0 0 8 16.001">
        <path d="M2 5.333H0V8h2v8h3.333V8h2.428L8 5.332H5.333v-1.11c0-.636.128-.89.744-.89H8V0H5.461C3.064 0 2 1.055 2 3.076z" />
    </symbol>
    <symbol id="twitter" viewBox="0 0 24 20">
        <path d="M24 2.309a9.83 9.83 0 0 1-2.828.775A4.932 4.932 0 0 0 23.337.36a9.864 9.864 0 0 1-3.127 1.195A4.916 4.916 0 0 0 16.616 0c-3.179 0-5.515 2.966-4.797 6.045A13.978 13.978 0 0 1 1.671.901a4.93 4.93 0 0 0 1.523 6.574 4.903 4.903 0 0 1-2.229-.616c-.054 2.281 1.581 4.415 3.949 4.89a4.935 4.935 0 0 1-2.224.084 4.928 4.928 0 0 0 4.6 3.419A9.9 9.9 0 0 1 0 17.292a13.94 13.94 0 0 0 7.548 2.212c9.142 0 14.307-7.721 13.995-14.646A10.025 10.025 0 0 0 24 2.309z" />
    </symbol>
    <symbol id="google-plus" viewBox="0 0 24 14">
        <path fill-rule="evenodd" clip-rule="evenodd" d="M7 6v2.4h3.97c-.16 1.029-1.2 3.02-3.97 3.02-2.39 0-4.34-1.979-4.34-4.42 0-2.44 1.95-4.42 4.34-4.42 1.36 0 2.27.58 2.79 1.08l1.9-1.83C10.47.69 8.89 0 7 0 3.13 0 0 3.13 0 7s3.13 7 7 7c4.04 0 6.721-2.84 6.721-6.84 0-.46-.051-.81-.111-1.16H7z" />
        <path d="M21 3h-2v3h-3v2h3v3h2V8h3V6h-3V3z" />
    </symbol>
    <symbol id="linkedin" viewBox="0 0 24 23">
        <path d="M4.98 2.5A2.49 2.49 0 0 1 2.5 5 2.49 2.49 0 0 1 .02 2.5C.02 1.12 1.13 0 2.5 0a2.49 2.49 0 0 1 2.48 2.5zM5 7H0v16h5V7zm7.982 0H8.014v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0V23H24V12.869c0-7.88-8.922-7.593-11.018-3.714V7z" />
    </symbol>
    <symbol id="youtube-play" viewBox="0 0 24 18">
        <path d="M19.615.184c-3.604-.246-11.631-.245-15.23 0C.488.45.029 2.804 0 9c.029 6.185.484 8.55 4.385 8.816 3.6.245 11.626.246 15.23 0C23.512 17.55 23.971 15.196 24 9c-.029-6.185-.484-8.549-4.385-8.816zM9 13V5l8 3.993L9 13z" />
    </symbol>
    <symbol id="download-icon" viewBox="0 0 12 14">
        <path d="M7.57 6.587h2.615L6 10.43 1.815 6.587h2.616V0h3.138v6.588zm2.86 4.118v1.647H1.57v-1.647H0v3.294h12v-3.294h-1.57z" />
    </symbol>
    <symbol id="contents-icon" viewBox="0 0 24 20">
        <path d="M13 4H0V0h13v4zm0 4H0v4h13V8zm0 8H0v4h13v-4zm3-8l4 5.075L24 8h-8z" />
    </symbol>
    <symbol id="paperclip" viewBox="0 0 16 18">
        <path fill-rule="evenodd" clip-rule="evenodd" d="M12.674 0c1.728 0 3.13 1.434 3.13 3.2 0 .324-.042 1.395-.956 2.302l-6.772 6.926c-.477.55-1.696 1.047-2.64.081-.942-.963-.468-2.197.071-2.692L9.034 6.21l.566.578-2.531 2.588.011.003-1.129 1.156.003.002c-.776.942.495 2.398 1.582 1.286l6.706-6.86c.525-.533.752-1.139.752-1.762 0-1.31-1.039-2.373-2.32-2.373-.626 0-1.196.254-1.614.67l-.002-.003-9.228 9.431-.001-.002A3.714 3.714 0 0 0 .8 13.5c0 2.031 1.614 3.682 3.6 3.682.52 0 1.472.006 2.816-1.365l8.218-8.4.566.578-8.382 8.572A4.344 4.344 0 0 1 4.4 18C1.972 18 0 15.983 0 13.5c0-1.29.533-2.454 1.385-3.276C9.919 1.496 10.053 1.356 10.42.981 10.642.754 11.393 0 12.674 0z" />
    </symbol>
</svg>
<script>"use strict";var wprRemoveCPCSS=function wprRemoveCPCSS(){var elem;document.querySelector('link[data-rocket-async="style"][rel="preload"]')?setTimeout(wprRemoveCPCSS,200):(elem=document.getElementById("rocket-critical-css"))&&"remove"in elem&&elem.remove()};window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);</script><noscript><link rel="stylesheet" href="https://blog.devart.com/wp-content/cache/min/1/386643c3d2d3735be5794309a2354d87.css" media="all" data-minify="1" /><link href="https://fonts.googleapis.com/css?family=Fira+Sans:100,100i,200,200i,300,300i,400,400i,500,500i,600,600i,700,700i,800,800i,900,900i|Open+Sans:300,300i,400,400i,600,600i,700,700i,800,800i&#038;display=swap" rel="stylesheet" /></noscript></body> 
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1621415021 -->